Setting Mikrotik Anti Hack Protected BootLoader

Halo gan, kali ini saya akan membagikan tutorial cara Setting Mikrotik Anti Hack Protected BootLoader , untuk melindungi kita dari hacker  yang ingin berbuatj jahat pada server mikrotik kita.

Cara kerja script ini simple tapi smart, script ini akan memonitor siapa saja yang berniat untuk mengaktifkan Mikrotik Protected Bootloader, dan akan langsung terdeteksi dan otomatis router akan langsung melakukan shutdown, dan pada saat router dihidupkan kembali semua maka settingan Protected Bootloader akan dikembalikan ke pengaturan default, sehingga tindakan hack dari penyusup jahat sebelumnya akan sia-sia.

Jika setelah install script ini, router akan reboot dan mati sendiri tetapi jangan panik dulu, bisa jadi scriptnya  bekerja dan bisa jadi berarti ada yang mencoba mengaktifkan bootloader di router secara illegal, kalau benar ini bisa di lihat dengan mengubah keterangan jendela atau identitas di Winbox menjadi BOOTLOADER> Min: 00:00:20 – Maks: 00:10:00

Mengapa script ini harus merubah identitas atau caption di winbox? Saya mencoba berpikir jika tombol reset dan NetInstall tidak berfungsi setidaknya kita tahu berapa lama waktu yang diperlukan untuk menekan tombol reset agar berfungsi kembali. Silahkan dimodifikasi sendiri, jika ingin bagus lagi, kami juga dapat menambahkan informasi lain seperti mengirimnya ke email atau ke telegram

Sebagai informasi tambahan, sebenarnya script ini tidak hanya bisa dijalankan melalui schedule saja, karena masih banyak celah yang bisa kita gunakan untuk menginstal script tersebut.

Beberapa lokasi yang dapat diinstal untuk menjalankan skrip ini:
– DHCP Client
– DHCP Server
– Hotspot Profile
– PPP Profile
– Netwatch tool

#=====================================================
# ANTI HACKER PROTECTED BOOTLOADER BY BUANANET SECURE!
#=====================================================
# Set Local String
:local logprotectedrouterboot;
:local logreformatholdbutton;
:local logreformatholdbuttonmax;
# Set local Input
:set logprotectedrouterboot "$[/system routerboard setting get protected-routerboot]"
:set logreformatholdbutton "$[/system routerboard setting get reformat-hold-button]"
:set logreformatholdbuttonmax "$[/system routerboard setting get reformat-hold-button-max]"
# Ckeck if Bootloader change to Enable
:if ($logprotectedrouterboot ="enabled") do={
# Set info reformat hold button on Identity
/system identity set name="BOOTLOADER > Min:$logreformatholdbutton - Max:$logreformatholdbuttonmax"
# Set back BootLoader to default config
/system routerboard setting set protected-routerboot disabled
/system routerboard setting set reformat-hold-button=20s
/system routerboard setting set reformat-hold-button-max=10m
# delay 5 second
:delay 5s
# Shutdown mikrotik or use /system reboot
/system shutdown
} 

Credit: https://www.o-om.com/2020/10/script-mengamankan-protected-bootloader.html

Leave a Comment